Subscribed unsubscribe Subscribe Subscribe

ayucat.ch 2015-16

id:ayucatのぶろぐ (Nexus 5 (2015) / iPhone 6s / Galaxy S6 edge / iOS 9 / Ubuntu Trusty / Android 6.0 Marshmallow / Thunderbird / AWS / クラブ / 祭り / 花火 / 海 / 野外フェス)

fluentdのRPMのrequireが古い

sudo yum install td-agentしようとすると、

Resolving Dependencies
--> Running transaction check
---> Package td-agent.x86_64 0:1.1.11-0 will be installed
--> Processing Dependency: td-libyaml for package: td-agent-1.1.11-0.x86_64
--> Processing Dependency: libxslt for package: td-agent-1.1.11-0.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package: td-agent-1.1.11-0.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package: td-agent-1.1.11-0.x86_64
--> Processing Dependency: libyaml-1024.so.4()(64bit) for package: td-agent-1.1.11-0.x86_64
--> Processing Dependency: libtermcap.so.2()(64bit) for package: td-agent-1.1.11-0.x86_64
--> Processing Dependency: libreadline.so.5()(64bit) for package: td-agent-1.1.11-0.x86_64
--> Processing Dependency: libxslt.so.1()(64bit) for package: td-agent-1.1.11-0.x86_64
--> Processing Dependency: libexslt.so.0()(64bit) for package: td-agent-1.1.11-0.x86_64
--> Running transaction check
---> Package compat-libtermcap.x86_64 0:2.0.8-49.2.amzn1 will be installed
---> Package compat-readline5.x86_64 0:5.2-17.3.amzn1 will be installed
---> Package libxslt.x86_64 0:1.1.26-2.7.amzn1 will be installed
---> Package openssl098e.x86_64 0:0.9.8e-17.8.amzn1 will be installed
---> Package td-libyaml.x86_64 0:0.1.4-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================
 Package                                   Arch                           Version                                    Repository                            Size
================================================================================================================================================================
Installing:
 td-agent                                  x86_64                         1.1.11-0                                   treasuredata                          18 M
Installing for dependencies:
 compat-libtermcap                         x86_64                         2.0.8-49.2.amzn1                           amzn-main                             16 k
 compat-readline5                          x86_64                         5.2-17.3.amzn1                             amzn-main                            156 k
 libxslt                                   x86_64                         1.1.26-2.7.amzn1                           amzn-main                            555 k
 openssl098e                               x86_64                         0.9.8e-17.8.amzn1                          amzn-main                            894 k
 td-libyaml                                x86_64                         0.1.4-1                                    treasuredata                         125 k

Transaction Summary
================================================================================================================================================================
Install       6 Package(s)

てな感じで古いパッケージ(compat-libtermcap, compat-readline5, openssl098eあたり)を入れなきゃいけない問題はみなさんどうやって解決しているのかな?